1. <div id="wev0f"></div>

      || 您当前的位置£º首页 > SAP HR?#35797;?#32593;

      User Parameter Value not pulled into the transaction

      来源£º  作者£ºKatalin Gabriella Csengodi   (查看评论)
      Katalin Gabriella Csengodi  
      LE (Logistics Execution)
      SAP ERP enterprise resource planningsupply chain management

      Problem

      You wonder why the User Parameter Value, maintained in the User Profile (Transaction SU3), is not taken

      over in a transaction? You want to get a field filled by a certain value in a transaction and had set this in

      SU3, but it does not work?

      For example you want to have the output type 0001 already filled  in the transaction VL74.

      Setting the User Parameter Value

      Parameter ID can be seen among the Technical Information called by pressing F1 on the Output Type field:

      output F1.png
      output F1_B.png

      Parameter ID to use in this case is ¡°NAC¡±.

      User Parameter Value (USPARAM-PARVA) for the Parameter ID (USPARAM-PARID) is

      set in transaction SU3 (Also reachable from the Menu: System -> User Profile -> Own Data)

      For Parameter ID ¡°NAC¡± e.g. the Parameter Value ¡°0001¡± will be set:

      /wp-content/uploads/2013/10/su3_300926.png

      However after setting the User Parameter Value, the Output Type field is not filled with 0001 in the

      transaction VL74:

      /wp-content/uploads/2013/10/vl74_300932.png

      Analysis:

      Checking the F1 Help of the User Parameter ID (Transaction SU3) the prerequisite is showed:

      /wp-content/uploads/2013/10/prereq_300933.png

      As also stated in https://service.sap.com/sap/support/notes/12487: GPA/SPA user parameters not set

      ¡°Fetching of user parameters from the parameter pool or setting of parameters in the parameter pool must

      be explicitly programmed or accessed in the screen.  Therefore, the parameters that are set do not

      automatically apply to all transactions.

      To determine whether parameter values have been set in the standard system, use SE51 to check the

      attributes (SPA/GPA) of the relevant screen field to see if it is active; then check the PBO (process before

      output) module in the flow logic to see whether ¡°GET PARAMETER ID¡­¡±has been explicitly programmed.¡±

      Screen field used here is: ¡°RG_KSCHL-LOW¡±:

      /wp-content/uploads/2013/10/screen_300934.png

      Checking the screen attributes in the transaction SE51:

      /wp-content/uploads/2013/10/se51_entry_304988.png

      Program and Screen number is needed to where the Parameter Value should be taken over, so call

      transaction VL74 and go to  Menu -> System -> Status:

      /wp-content/uploads/2013/10/systemdetails_300935.png

      Call SE51 with these data :

      Program: SD70AV6A

      Screen number: 1000

      /wp-content/uploads/2013/10/se51_attributes_304981.png

      se51_element list.png

      The SET and GET parameters and the Parameter ID are NOT set for the concerned screen.

      That means one of the prerequisities is not met.

      Checking the Flow Logic:

      se51_flow logic.png

      ¡°GET PARAMETER ID¡­¡±is not programmed. The second prerequisity is neither met.

      Summary:

      The Parameter Value, set for the Parameter ID ¡°NAC¡±, will not be taken over from the User

      Parameter setting into VL74 as it is not set in the standard system:

      1. The Set and Get Parameters are not activated for the relevant screen AND

      2. ¡°Get parameter ID¡± is not programmed.

      The prerequisities are not met, the requisted functionality is not programmed in SAP Standard.

      You have to do your own proramming for this special screen.

      考试辅导
      最近更新内容
      Google广告
      °²»Õ¿ì3ÔõôÍæ

      1. <div id="wev0f"></div>

        1. <div id="wev0f"></div>